Bez ręki

Znowu zabrałem się za upgrade – tym razem wszystko poszło dobrze, mimo tego, że znowu porwałem się na aktualizację drakśmaków i perla :)

Wszystko działa jak należy, z małym wyjątkiem… W zależnościach poleciał nowy Python (teraz mam 2.4). Po tym współpracy odmówiło JPA. Aż taki głupi nie jestem, by nie zrozumieć komunikatów więc odświeżyłem PyQT. Po kolejnej odmowie pracy ten sam los spotkał Sip. Teraz JPA już się uruchamia, ale nie chce wysłać wiadomości. A pomysły na naprawę już się skończyły, bo komunikaty

Traceback (most recent call last):
  File "/opt/jpa/lib/qjt_main.py", line 191, in msgSend
    self.sender.send(msg)
  File "/opt/jpa/lib/qjt_msgsend.py", line 37, in send
    sender.run()
  File "/opt/jpa/lib/qjt_msgsend.py", line 72, in run
    transport.send(self.message)
  File "/opt/jpa/lib/jt_transport2.py", line 78, in send
    self.conn.registerHandler('message', self.msgCallback)
AttributeError: registerHandler

nie sugerują już rozwiązania… :(

Jak ja nie cierpię ręcznego klepania HTML we wpisach na joggu.

Może Ci się również spodoba

  • DoomHammer

    Sam żeś się zBOFHował :P

  • da.killa

    Ano :)

    Jutro sprawdzę czy wersja JPA z CVS zadziała :)

  • da.killa

    Już sprawdziłem. Revision 21 z SVN daje takie same efekty :(

  • zgoda (jarek)

    registerHandler() to metoda z jabberpy, panie kolego. Którą wersję używasz i czy masz "świeżą"? Pamiętaj, że kompilaty Pythona nie są zgodne ani wstecz, ani wprzód — po przejściu na 2.4 musisz od nowa zainstalować wszystkie biblioteki, przedsmak tego miałeś z SIP (w ogóle powinieneś był instalować PyQt i SIP w odwrotnej kolejności, ale skoro działa, to git).

  • da.killa

    Dziękuję za pomoc! Po reinstalacji jabber.py zaczęło działać jak należy.